本段代码演示了易语言如何从一个完整路径的文件名中取出该文件所在的路径,子程序 取文件路径 () 有一个参数,填写完整路径的文件名。
----------
.版本 2
.程序集 程序集, , , 演示易语言从完整文件名中取出所在路径
.子程序 _启动子程序, 整数型, , 本子程序在程序启动后最先执行
信息框 (取文件路径 (“d:\files\document.docx”), 64, , )
返回 (0) ' 可以根据您的需要返回任意数值
.子程序 取文件路径, 文本型, 公开, 从一个完整的文件名中取出文件所在路径,例如文件名为:d:\music\yinyue\sound.mp3,所在路径为 d:\music\yinyue\
.参数 文件名, 文本型, , 含有完整路径的文件名
返回 (取文本左边 (文件名, 倒找文本 (文件名, “\”, , 假)))
----------

使用快搜查找更多与 《易语言获取文件所在路径》 有关的信息

标签: 易语言

添加新评论