本段代码演示了如何从完整文件名中取出不含所在文件夹路径的文件名,子程序 取文件名 () 有一个参数,填写完整路径的文件名。
----------
.版本 2
.程序集 程序集, , , 演示易语言如何从完整路径中取出文件名
.子程序 _启动子程序, 整数型, , 本子程序在程序启动后最先执行
信息框 (取文件名 (“c:\b\love.me”), 64, , )
返回 (0)
.子程序 取文件名, 文本型, 公开, 从完整的文件路径名中取出文件名,例如原文件名为:d:\files\document.doc 返回的结果为 document.doc
.参数 文件名, 文本型, , 原文件名
.参数 是否带扩展名, 逻辑型, 可空, 返回的文件名中是否含有扩展名
.局部变量 filename, 文本型
是否带扩展名 = 选择 (是否为空 (是否带扩展名), 真, 是否带扩展名)
filename = 取文本右边 (文件名, 取文本长度 (文件名) - 倒找文本 (文件名, “\”, , 假))
.如果真 (删全部空 (filename) = “”)
filename = 取文本右边 (文件名, 取文本长度 (文件名) - 倒找文本 (文件名, “\”, 取文本长度 (文件名) - 1, 假))
filename = 取文本左边 (filename, 取文本长度 (filename) - 1)
.如果真结束
.如果真 (是否带扩展名 = 假)
filename = 取文本左边 (filename, 倒找文本 (filename, “.”, , 假) - 1)
返回 (filename)
.如果真结束
返回 (filename)
----------

使用快搜查找更多与 《易语言从完整路径中取出文件名》 有关的信息

标签: 易语言

添加新评论