.版本 2
.程序集 程序集, , , 演示易语言从一段长文本中开始点和结束点两个关键词中取出文本
.子程序 _启动子程序, 整数型, , 本子程序在程序启动后最先执行
信息框 (取中间文本 (“abcdefghi”, “c”, “g”), 64, , )
返回 (0) ' 可以根据您的需要返回任意数值
.子程序 取中间文本, 文本型, 公开, “取得开始点和结束点指定文本中间的内容”
.参数 原始文本, 文本型, , 要提取的元文本
.参数 起点文本, 文本型, , 要提取内容的起始文本
.参数 节点文本, 文本型, , 要提取内容的节点文本
.参数 是否区分大小写, 逻辑型, 可空, 在搜索匹配过程中是否区分大小写。真区分,假不区分。。
.参数 贪婪模式, 逻辑型, 可空, 采用贪婪模式匹配会尽可能匹配更长的文本
.局部变量 文本, 文本型
文本 = 选择 (贪婪模式, 取文本中间 (原始文本, 寻找文本 (原始文本, 起点文本, , 取反 (是否区分大小写)), 倒找文本 (原始文本, 节点文本, , 取反 (是否区分大小写)) - 寻找文本 (原始文本, 起点文本, , 取反 (是否区分大小写))), 取文本中间 (原始文本, 寻找文本 (原始文本, 起点文本, , 取反 (是否区分大小写)), 寻找文本 (原始文本, 节点文本, 寻找文本 (原始文本, 起点文本, , 取反 (是否区分大小写)), 取反 (是否区分大小写)) - 寻找文本 (原始文本, 起点文本, , 取反 (是否区分大小写))))
文本 = 子文本替换 (文本, 起点文本, “”, , 1, 真)
返回 (文本)

使用快搜查找更多与 《易语言取中间文本》 有关的信息

标签: 易语言

添加新评论