本段代码演示了易语言如何获得随机生成的字符串,子程序 取随机字符串() 只有一个参数,用于指定要取出字符串的字数。
----------
.版本 2
.程序集 程序集, , , 演示易语言取随机字符串
.子程序 _启动子程序, 整数型, , 本子程序在程序启动后最先执行
信息框 (取随机字符串 (9), 64, , ) ' 获取大小写混合的字符串
信息框 (到大写 (取随机字符串 (10)), 64, , ) ' 获取全部为大写字母的字符串
信息框 (到小写 (取随机字符串 (100)), 64, , ) ' 获取全部为小写字母的字符串
返回 (0)
.子程序 取随机字符串, 文本型, 公开, 获取指定字符数量的随机字符串(包括英文和数字)
.参数 字符数量, 整数型, 可空, 要获取的字符数量(本参数可空,若为空,默认为5,取出5个随机字符)
.局部变量 n, 整数型
.局部变量 zf, 文本型, , "0"
.局部变量 str, 文本型
置随机数种子 ()
.如果真 (是否为空 (字符数量) = 真)
字符数量 = 10
.如果真结束
.计次循环首 (10, n)
加入成员 (zf, 字符 (n + 47))
处理事件 ()
.计次循环尾 ()
.计次循环首 (26, n)
加入成员 (zf, 字符 (n + 64))
处理事件 ()
.计次循环尾 ()
.计次循环首 (26, n)
加入成员 (zf, 字符 (n + 96))
处理事件 ()
.计次循环尾 ()
.计次循环首 (字符数量, )
str = str + zf [取随机数 (1, 62)]
处理事件 ()
.计次循环尾 ()
返回 (str)
----------

使用快搜查找更多与 《易语言取随机字符》 有关的信息

标签: 易语言

添加新评论