这是一段易语言枚举文件的源代码示例,演示了如何创建文件索引并将文件名保存到数组中。
可以用这段代码来构建搜索索引列表。

.版本2
.程序集易语言程序
.程序集变量临时搜索结果列表
.子程序创建索引,逻辑型,公开,枚举文件,创建文件搜索索引列表,成功返回true;失败返回false
.参数目录,文本型,,要创建索引的起始目录
.参数搜索结果列表,文本型,可空数组,保存索引结果的文本数组
.局部变量临时文件名,文本型
.如果真(是否为空(搜索结果列表)=假)
清除数组(临时搜索结果列表)
.如果真结束
目录=选择(取文本右边(目录,1)=“\”,目录,目录+“\”)
临时文件名=寻找文件(目录+“*”,16)
.判断循环首(临时文件名≠“”)
.如果真(临时文件名≠“.”且临时文件名≠“..”)
'加入成员(临时搜索结果列表,目录+临时文件名+“\”)
创建索引(目录+临时文件名+“\”)
.如果真结束
临时文件名=寻找文件(,16)
处理事件()
.判断循环尾()
临时文件名=寻找文件(目录+“*”,)
.判断循环首(临时文件名≠“”)
.如果真(临时文件名≠“.”且临时文件名≠“..”)
加入成员(临时搜索结果列表,目录+临时文件名)
.如果真结束
临时文件名=寻找文件(,)
处理事件()
.判断循环尾()
.如果真(是否为空(搜索结果列表)=假)
搜索结果列表=临时搜索结果列表
.如果真结束
返回(选择(取数组成员数(搜索结果列表)>0,真,假))

【本文由赐荣小站原创,转载请注明出处。】

使用快搜查找更多与 《易语言如何枚举磁盘上的文件》 有关的信息

标签: 易语言

仅有一条评论

  1. epl epl

    感谢作者,学习了。

添加新评论